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1 Introduction

The Molecular Dynamics (MD) showcase project aims to create web-based platforms to

showcase and share molecular structures and MD simulation trajectories. It has resulted

in two tools: the visualization tool (Molecular Dynamics Showcase) and the builder tool

(Molecular Dynamics Showcase Builder). Both tools are hosted at https://nanohub.org/

and are free to everyone:

• Molecular Dynamics Showcase https://nanohub.org/tools/mdshowcase

• Molecular Dynamics Showcase Builder https://nanohub.org/tools/mdshowbuilder

The visualization tool allows users to visualize and interact with MD simulation tra-

jectories online, without installing any visualization or simulation software or having any

simulation experience. The builder tool allows users familiar with molecular visualization

software (e.g. VMD), to showcase either a molecular structure or a simulation trajectory to

everyone. The author of the showcase can use it to collaborate with other scientists or to

create a lesson about a microscopic world.

In this tutorial, we will focus on using the builder tool to create a showcase. We will

start with the simplest example – creating a showcase from a PDB file – before explor-

ing, step-by-step, more complicated examples. We will cover how to add a description,

change perspective, and add frame-related comments. It is assumed that the reader of

this tutorial has finished the VMD tutorial (http://www.ks.uiuc.edu/Training/

Tutorials/vmd/tutorial-html/). If you encountered any problems or bugs while using

this tutorial, please don’t hesitate to contact Aksimentiev group (http://bionano.physics.

illinois.edu/people/aleksei-aksimentiev).

Prerequisites:

• VMD program

• A command-line interface terminal

• A Java-enabled web browser

1.1 Content of the tutorial files

The hierarchy of subdirectories extracted from “mdshowcaseTutorial.tar.gz”:

• mdshowcaseTutorial

– ch2

https://nanohub.org/
https://nanohub.org/tools/mdshowcase
https://nanohub.org/tools/mdshowbuilder
http://www.ks.uiuc.edu/Training/Tutorials/vmd/tutorial-html/
http://www.ks.uiuc.edu/Training/Tutorials/vmd/tutorial-html/
http://bionano.physics.illinois.edu/people/aleksei-aksimentiev
http://bionano.physics.illinois.edu/people/aleksei-aksimentiev
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∗ 1h WI dna.pdb

∗ 1h npt dna.tcl

∗ example output

– ch3

∗ 1h WI dna.pdb

∗ 1h npt dna.tcl

∗ example output

∗ replicate.tcl

∗ rockandroll.tcl

∗ rotate.tcl

∗ view example 0.tcl

∗ view example 1.tcl

– ch4

∗ 1h WI.psf

∗ 1h WI npt.dcd

∗ 1h npt.tcl

∗ example output

∗ funnel E100mV.tcl

∗ funnel WI cS f rm c aC dna.psf

∗ funnel WI cS f rm c aC lip.psf

∗ funnel WI cS f rm c aC pot.psf

∗ loadFunnel.tcl

∗ movie dna E100mV.xtc

∗ movie lip E100mV.xtc

∗ movie pot E100mV.xtc

– ch5

∗ 1h.bib

∗ 1h npt comment.html

∗ 1h npt description.html

∗ 1h npt snapshot.tga

∗ 1h npt view.tcl

∗ example output

∗ funnel.bib

∗ funnel E100mV description.html

∗ funnel E100mV snapshot.tga
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Each subdirectory (ch2, ch3, ch4 and ch5) contains the associated files for each section.

If your archive does not contain all the files in the list, please download the latest version

from Aksimentiev group website (http://bionano.physics.illinois.edu/).

1.2 Introduction to a showcase

Showcase: URL0

Scene 1: URL1

Molecule 1_1
Trajectory 1_1
Molecule 1_2
Trajectory 1_2

.

.

.

Scene 2: URL2 Scene 3: URL3 ...

Molecule Description

Text
Snapshot

VMD script

Representation

View

Speed
Smooth
How to play the trajectory

Citation Comment

Frame-related comment

Figure 1: The structure of a showcase.

The basic structure of a showcase can be illustrated in Figure 1. Once a showcase is shared,

a URL will be assigned to it. A showcase can contain many scenes, and each scene has its

own URL. A scene contains the following:

• Molecule: A collection of molecules (PSF and PDB files), and their trajectories (DCD,

XTC or other trajectory file format).

• Description: Description text and a thumbnail image.

• VMD script: VMD script for defining representation and perspective.

• View: Speed, smoothness, and how to play the trajectory. You can also add custom

script to rotate or zoom while playing the trajectory.

• Citation: The citation for the current scene.

• Comment: The comment or description which only appear at certain frames.

http://bionano.physics.illinois.edu/
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1.3 Found a bug in the tool

Figure 2: Go to “SUPPORT” > “Tickets” to submit a ticket.

If the MD showcase or MD showcase builder tool crashes for unknown reasons, please submit

a ticket directly through nanoHUB. You can submit a ticket by going to “SUPPORT” >

“Tickets” on the nanoHUB web page (Figure 2).
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Figure 3: An example ticket. It is best to provide the name of the tool, steps needed to

reproduce the bug (if applicable) and a snapshot of the error or error message.

Figure 3 is an example of a ticket. To make the communication (ticket) more effective,

please specify the name of the tool, the detailed steps needed to reproduce the bug (if

applicable) and a snapshot image of the bug.

We apologize for any inconvenience caused by bugs in the beta
versions of the tools, and we appreciate your report to help us
improve them!

2 Create the first showcase

Please navigate to the ch2 folder.

For this section, the guide use a PDB file (“1h WI dna.pdb”) containing a DNA du-

plex. [1] Feel free to use your own PDB file in its place. The DNA duplex is functionalized

with 6 porphyrin groups. First, let’s load the PDB file in VMD. Next, let’s create some nice

representation for this molecule. You can use your favorite text editor to open the PDB file

and examine what residues are in this PDB file. Alternatively, you can use the following

command in the TkConsole to display each chain and resname:
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set all [atomselect top all]

# get all unique resname

lsort -unique [$all get resname]

# get all unique chains

lsort -unique [$all get chain]

You can choose any representation you like. For details about VMD representation, please

refer to VMD tutorial (http://www.ks.uiuc.edu/Training/Tutorials/vmd/tutorial-html/)

or VMD User’s Guide (http://www.ks.uiuc.edu/Research/vmd/current/ug/). Here, we

also provided an example representation in the “1h npt dna.tcl” (However, if you use your

own PDB file, the example representations may not work well.) You can simply type the

following command in the TkConsole to use the example representation:

source 1h_npt_dna.tcl

Once you are satisfied with the representation and viewpoint, you can save the VMD state

by going to “File” > “Save Visualization State” (Figure 4). Let’s save it as “1h 1.vmd”.

Figure 4: Save VMD state.

Next, open a web browser and go to https://nanohub.org/tools/mdshowbuilder, the

page of MD showcase builder (Figure 5) and launch the MD showcase builder.

http://www.ks.uiuc.edu/Training/Tutorials/vmd/tutorial-html/
http://www.ks.uiuc.edu/Research/vmd/current/ug/
https://nanohub.org/tools/mdshowbuilder
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Figure 5: The MD showcase builder tool page. Click “Launch Tool” to start MD showcase

builder.

2.1 Create a scene in the showcase

Now, we will create our first showcase. If you are unable to finish the previous section, you

can use the “example output/1h 1.vmd” to continue.

We provide complete step-by-step snapshots for this section, from Figure 6

to Figure 20. You can finish this section by simply following the snapshots.

However, if you would like to know more detail or encounter any issue, we

suggest going through the description.

Figure 6 is the main window of the MD showcase builder. From the left of the first row,

the “File” button allows you to open a previously saved showcase file, save a showcase file,

share a showcase file, upload a file to your nanoHUB workspace or download a file from

your workspace to your desktop. The “Load Example” button allows you to load example

showcase files to get started. The “Preview” button allows you to preview the showcase you

loaded or made. The middle part is the scene section, where you can add, delete, reorder or

copy scenes. The bottom part is the citation section, where you can add, delete or reorder

citations. Since now we are at the showcase level (the top level in Figure 1), the citation is

for the entire showcase.
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Figure 6: The MD showcase builder main window. Click “Add Scene” to add a new scene.

By default, we are at a new showcase. Let’s click “Add Scene” to add a new scene

(Figure 6). Then, move the mouse to “New scene #1” and the “Edit” button will appear.

Click “Edit” to edit the scene (Figure 7).
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Figure 7: Move the mouse to “New scene #1” and the “Edit” button will appear. Click

“Edit” to edit the scene.

Figure 8 is the scene window of the MD showcase builder. The top column is the scene

name. The second part is the molecule section, where you can add, delete and edit molecules.

The molecule section corresponds to the molecule component in Figure 1. On the bottom

left of the molecule section, there is a “Load Save State File” button, which you can use

the VMD state file to create a scene. At the last section of the window, there are five tabs

“Description”, “VMD script”, “View”, “Citation” and “Comment”, corresponding to the

other five components of a scene in Figure 1.

Although you can also create a scene from scratch (adding molecule and adding VMD

script), in this tutorial you will create a scene using VMD state file (Figure 7).
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Figure 8: Click “Load Save State File” to create the scene with the VMD state file.

When we create a scene with the VMD state file, all of the related files (PSF, PDB, DCD

and so on) have to be in the same folder. So, let’s create a “mdshowcaseTutorial” folder and

a “ch2” folder inside it (Figure 9 to Figure 11).
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Figure 9: Click “Create a new folder”.

Figure 10: Right-click on the new folder to rename it. Let’s call it “mdshowcaseTutorial”.
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Figure 11: And create another folder “ch2” inside “mdshowcaseTutorial”.

Then, we have to upload the PDB file (“1h WI dna.pdb”) and the VMD state file

(“1h 1.vmd”), Figure 12 to Figure 14



2 CREATE THE FIRST SHOWCASE 14

Figure 12: Click “Import a file from your desktop”.

Figure 13: First, select the PDB file.
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Figure 14: Then, import the VMD state file. Change the file type to “All Files” to make

sure both files are present.

After we open the VMD state file, the information from the VMD state file will be

extracted (Figure 15).
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Figure 15: Click the .vmd file and “Open” to open the VMD state file.

Figure 16: The molecule and the “VMD script” tab will be populated with information from

the VMD state file.
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The molecule section and the VMD script section will be populated with the information

from the VMD state file (Figure 16).

Figure 17: Change the name of the scene.
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Figure 18: Click “Preview” to preview the scene. It should look exactly as we saw it in

VMD.

Now, we can change the name of the scene (Figure 17) and preview our first scene

(Figure 18).
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Figure 19: Click “Exit Preview” and then “Back” to go back to the main window. Click

“File” > “Save Showcase As”.

Figure 20: Save it as 1h 1.sho.
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Finally, to save our work, we need to go back to the main window. Then, we need to

click “File” > “Save Showcase As” to save the showcase file (Figure 19). Let’s save it as

“1h 1.sho” (Figure 20).

2.2 Share the showcase

We have saved the showcase file in the workspace. Now, how can we share it?

Figure 21: Click “File” > “Share Showcase Draft”.

First, Click “File” > “Share Showcase Draft” in the MD showcase main window (Fig-

ure 21).
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Figure 22: Select the “1h 1.sho” and click “Open”.

Then, select the “1h 1.sho” and click “Open” (Figure 22).
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Figure 23: Copy the URL.

A pop-up window will appear, displaying the URL of the shared showcase. If there are

multiple scenes in the showcase, it will also show all the URLs to each scene. Let’s copy the

URL (Figure 23).
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Figure 24: Paste it in the browser.

Figure 25: It will launch MD showcase, displaying the showcase we just created.
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Finally, just paste the URL in the browser (Figure 24). It will launch MD showcase,

displaying the showcase we just created (Figure 25). You can share the URL with others,

and they can interactively explore your molecular system.

Congratulations on creating your first showcase!

3 Create an animated showcase

Please navigate to the ch3 folder.

In the previous section, we created a showcase with a PDB file. Most PDB files down-

loaded from RCSB Protein Data Bank (http://www.rcsb.org/) contain the coordinates of

each atom in only one configuration. In other words, it contains only a single frame of a

movie or trajectory. As a result, if you click the play button in VMD or in the showcase

we made in the previous section, it will not play because there is no “next frame”. In this

section, we will introduce some tricks to create an animated showcase using a PDB file with

only one frame.

3.1 Rotation

One of the simplest and most commonly used molecular animations in scientific presentations

is the rotation of a molecule (ex. protein). Here, we will use a script to create a rotating

trajectory from the PDB file we used in the previous section.

Please type the following command in a terminal:

vmd -dispdev text -args 1h_WI_dna.pdb rotate.dcd 180 360 z < rotate.tcl

This script takes 5 arguments, the name of PDB (1h WI dna.pdb), the name of output

DCD (rotate.dcd), the number of frames (180), the degrees of rotation (360) and the axis of

rotation (z).

If you had difficulty creating the file “rotate.dcd”, you can use the example file in “ex-

ample output/rotate.dcd” to continue the tutorial.

Next, you can load the PDB file “1h WI dna.pdb” and the DCD file “rotate.dcd” in VMD

and define the representation you like. You can again use the same example representation in

“1h npt dna.tcl” Next, you can save the VMD state “rotate.vmd” as we did in the previous

section.

If you were unable to create the file “rotate.vmd”, you can use the example file in “ex-

ample output/rotate.vmd” to continue the tutorial.

http://www.rcsb.org/
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Figure 26: Upload “1h WI dna.pdb”, “rotate.dcd” and “rotate.vmd” and use “rotate.vmd”

to create the scene.

Finally, launch the MD showcase builder, create the “mdshowcaseTutorial/ch3” folder in

your workspace, upload the PDB file “1h WI dna.pdb”, the DCD file “rotate.dcd” and the

VMD state file “rotate.vmd”, Figure 26. Then, you can create the scene using the VMD

state file, save the showcase and share the showcase as we did in the previous section.

3.2 Rock and roll

In this section, we will create an animated trajectory with a fancier “Rock and Roll” motion.

Please type the following command in a terminal:

vmd -dispdev text -args 1h_WI_dna.pdb rockandroll.dcd 180 < rockandroll.tcl

Except for the file name of PDB and DCD, the only argument is the number of frames

you want. Then, you can follow the same process as in the previous section to make and

share the showcase.

In case any problem occurs, we provided “rockandroll.dcd” and “rockandroll.vmd” in the

“example output” folder. You can use them to continue the tutorial.
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3.3 Controlling the camera with a “view script”

The “View” tab in the MD showcase builder (Figure 1 and Figure 8) provides extensive

functionality for designing how to play the trajectory. To test how it works, let’s create a

“static” trajectory in which each frame is the same.

Please type the following command in a terminal:

vmd -dispdev text -args 1h_WI_dna.pdb replicate.dcd 180 < replicate.tcl

Except for the file name of the PDB and output DCD, the only argument is the number

of frames you want. Then, follow the same process as in the previous section to make the

showcase. After loading the VMD state file, let’s go to the “View” tab, Figure 27.

Figure 27: The “View” tab.

In the “View” tab, the “Frame Range” defines where those view functions below take

effect. “When the scene is loaded” defines how you want it to play, including once, in a

loop, forward, backward and back forth. You can also tune the default playing speed and

smoothness. In the last part, you can adjust the view using a script. Let’s click “Add script”

and upload the “view example 0.tcl”.

The content of the script is the following:
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if {($frame >=0) && ($frame < 45)} {

rotate y by -2

} elseif {($frame >=45) && ($frame < 90)} {

rotate x by 2

} elseif {($frame >=90) && ($frame < 135)} {

rotate z by 2

} elseif {($frame >=135) && ($frame < 180)} {

rotate x by -2

}

The script divides the trajectory into 4 parts. In each part, the view rotates along

different axes. In the end, the script will rotate the view back to the original perspective.

Now you can follow the same process as in the previous section to save and share the

showcase.

In case any problem occurs, we provided “replicate.dcd” and “replicate.vmd” in the

“example output” folder. You can use them to continue the tutorial.

3.4 Combine previous examples with a view script

In this section, we demonstrate how to combine the animated trajectory (Rotation and Rock

and roll section) with a view script (Design animation with a view script section).

Please open the showcase you made in the Rock and roll section. Go to the “View” tab

and add “view example 1.tcl”. Click “Preview” and you should see the power of combining

the two methods.

Then, you can follow the same process as in the previous section to save and share the

showcase.

4 Create multiple scenes with MD simulation trajec-

tories

Please navigate to the ch4 folder.

So far, we have only animated trajectories created by a script and a static PDB file.

What if we have a simulation trajectory? The process is the same.

4.1 Create a showcase with a MD trajectory

First, let’s load “1h WI.psf” and “1h WI npt.dcd” into VMD and visualize with the rep-

resentation defined in “1h npt.tcl”. Next, save the VMD state as “1h npt.vmd”. Launch

the MD showcase builder and create “mdshowcaseTutorial/ch3” folder in your workspace.
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Then, upload “1h WI.psf”, “1h WI npt.dcd” and “1h npt.vmd” into the “ch4” folder and

use “1h npt.vmd” to create the scene, Figure 28.

Figure 28: Use “1h npt.vmd” to create the scene.

If the trajectory file size is too large (ex. > 1GB), it is recommended to use sftp (ex.

“sftp username@nanoHUB.org”, read the sftp tutorial for details).

https://www.digitalocean.com/community/tutorials/how-to-use-sftp-to-securely-transfer-files-with-a-remote-server
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Figure 29: Preview of the showcase made with a simulation trajectory.

Then, if you set the playing speed to the maximum and smoothness to the minimum in the

“View” tab and change the scene name to “1h npt”, your showcase should look like Figure 29

when you click “Preview”.

Please save the showcase. We will continue to use it in the next section.

4.2 Add another scene with multiple molecules

As we illustrated in Figure 1, a showcase can contain more than one scene and a scene

can contain more than one molecule and trajectory. In this section, we will demonstrate

how to add another scene with multiple molecules. We will use a system containing a

funnel-shaped DNA origami channel [2]. The channel is functionalized with 19 cholesterol

groups and inserted into the lipid bilayer membrane. The entire system contains 8 mil-

lion atoms. For systems of such size, it is common to split the simulation trajectory into

different parts based on atom groups to reduce memory usage, for example, the trajec-

tory of DNA channel “movie dna E100mV.xtc”, lipid membrane “movie lip E100mV.xtc”

and potassium ions “movie pot E100mV.xtc”. The original PSF is also split into “fun-

nel WI cS f rm c aC dna.psf”, “funnel WI cS f rm c aC lip.psf” and “funnel WI cS f rm c aC pot.psf”.

Then, we can load what we need and skip what we do not need (ex. water) to minimize

memory usage. The splitting of PSF and DCD is beyond the scope of this tutorial. Please

refer to psfgen User’s Guide and CatDCD manual for more information.

http://www.ks.uiuc.edu/Research/vmd/plugins/psfgen/ug.pdf
http://www.ks.uiuc.edu/Development/MDTools/catdcd/
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You might also notice that we are not using the common DCD files created by NAMD,

but XTC files. The XTC file is a more compressed trajectory format, commonly used in

GROMACS. Since MD showcase is powered by VMD, all file formats recognized by VMD,

such as GROMACS trajectory file format, can also be used in MD showcase. For the

conversion of DCD file to XTC file format, please refer to CatDCD manual and GROMACS

trjconv utility.

Now, please launch VMD within the “ch4” folder. Then, load the PSF files and the tra-

jectories and define the representations by typing the following command in the TkConsole:

source loadFunnel.tcl

source funnel_E100mV.tcl

Next, save the visualization state as “funnel E100mV.vmd”.

Figure 30: Add the second scene and click “Edit”.

Go back to MD showcase builder and open the showcase we made in the previous section.

Add the second scene and click “Edit”, Figure 30. Upload the VMD state file, all the PSF

and XTC files. Then, create the scene by “funnel E100mV.vmd”.

http://www.ks.uiuc.edu/Development/MDTools/catdcd/
http://manual.gromacs.org/programs/gmx-trjconv.html
http://manual.gromacs.org/programs/gmx-trjconv.html
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Figure 31: Create the scene by “funnel E100mV.vmd”.

Change the name of the scene to “funnel E100mV” and click “Preview”. The result

should look like Figure 32.
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Figure 32: Preview the second scene.

Now, you would see that there are two thumbnails at the bottom. If you click the first

one, it will show the first scene we made in the previous section.

Please keep the session or save the showcase We will continue to build on this showcase

in the next section.

5 Enrich the showcase

Please navigate to the ch5 folder.

Now, we have a nice showcase with two scenes. In this section, we will demonstrate how

to enrich the content of the showcase.

5.1 Add snapshots for each scene

Although we have two scenes in a showcase and thumbnails switching between them (Fig-

ure 32), it is hard to know which one is which without a proper image. So, let’s add images

for each scene as snapshots. Although we will use the example images in the “ch5” folder to

proceed, you can take snapshots of your system in VMD as well.

First, let’s create “mdshowcaseTutorial/ch5” folder in your workspace. Next, click “Edit”

the first scene and go to the “Description” tab.
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Figure 33: Click “Add image” to add snapshot.

Click “Add image” to add snapshot (Figure 33). Upload the two images “1h npt snapshot.tga”

and “funnel E100mV snapshot.tga” and use the “1h npt snapshot.tga” for the first scene

(Figure 34).
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Figure 34: Use “1h npt snapshot.tga” for the first scene.

And, use “funnel E100mV snapshot.tga” for the second scene (Figure 35).
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Figure 35: Use “funnel E100mV snapshot.tga” for the second scene.

Now, if you click “Preview”, you should see that the snapshot images have been used for

thumbnails (Figure 36).
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Figure 36: Snapshot images are used for thumbnails.

5.2 Add description

Now, we have the snapshots as thumbnails and names for each scene. But, it would be better

if there are some descriptions about what each scene shows. Let’s exit preview, click “Edit”

on the first scene and go to the “Description” tab. MD showcase builder supports two ways

of adding description: plain text or HTML. Adding plain text is easy: just type the text in

the block.
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Figure 37: Click “HTML File” and “Add file”.

Here, we will show how to add HTML description. Using HTML description, you can

easily change text font, color or adding a hyperlink. We provided two example HTML file

“1h npt description.html” and “funnel E100mV description.html”. Please refer to HTML

tutorial for basic usage of the HTML language.

Click “HTML File” and “Add file” in the “Description” tab (Figure 37). Go to “mdshow-

caseTutorial/ch5” and upload “1h npt description.html” and “funnel E100mV description.html”.

http://www.w3schools.com/html/
http://www.w3schools.com/html/
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Figure 38: Use “1h npt description.html” for the first scene.

Use “1h npt description.html” for the first scene and “funnel E100mV description.html”

for the second scene (Figure 38).

The result should look like Figure 39 and Figure 40.
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Figure 39: The first scene with description.

Figure 40: The second scene with description.
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5.3 Add frame-related comment

Sometimes, we want to highlight certain part of a trajectory, for example, the conformation

change of a protein. And, we may also want to add some specific comment to further

explain what happened during that period. Here, we will demonstrate the usage of adding

frame-related comments using the first scene as an example.

In the first scene, the presence of a DNA duplex in the lipid bilayer membrane caused

water molecules to move into the lipid membrane, covering the DNA duplex and forming a

water channel. However, the transparent water channel is not very visible in the presence

of the DNA duplex. So, let’s hide the DNA from frame 50 ∼ 100. We can achieve that by

using a view script. Let’s exit preview, click “Edit” on the first scene and go to the “View”

tab.

Figure 41: Add “1h npt view.tcl” as the view script.

Add “1h npt view.tcl” as the view script (Figure 41). In the script, we hide the DNA by

changing the material opacity used for DNA to 0 in frame 50 ∼ 100.
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Figure 42: Add “1h npt comment.html” as the frame-related comment.

Then, go to the “Comment” tab. Add a comment in frame 50 ∼ 100 and add “1h npt comment.html”

as the content of the comment (Figure 42).
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Figure 43: The comment will show up in frame 50 ∼ 100.

The “Comment” tab should look like Figure 43. You can add multiple comments with

different frame ranges. If the ranges of the comments overlap, the latter one will replace the

former one.
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Figure 44: The DNA disappeared and the comment appeared.

If we click “Preview”, it should look like Figure 44. There is a yellow region in the slide

bar, showing that comment will appear during this period. As we play into this period (the

slide bar move into the yellow region), the DNA disappears and the comment appears.

5.4 Add citation

In the last section, we will show how to add citations. You can add citations in the main

window (Figure 6) for the entire showcase, or add citations for each scene. Here, we will

show how to add citation for the first scene. The process is the same for adding citations of

the entire showcase.
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Figure 45: Go to “Citation” tab and click “Add”.

First, let’s go to the “Citation” tab and click “Add” (Figure 45).
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Figure 46: Click “Edit”.

Next, click “Edit” (Figure 46).
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Figure 47: Click “Load BibTeX citation”.

Click “Load BibTeX citation” on the bottom left (Figure 47).
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Figure 48: Select “1h.bib” on the desktop.

Select “1h.bib” on the desktop (Figure 48).
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Figure 49: Each column will be filled with data in the “1h.bib”.

The MD showcase builder will extract information in the “1h.bib” and fill each column

(Figure 49).
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Figure 50: Click “Preview” and “Cite this work”.

Finally, let’s click “Preview” and “Cite this work” to see if it works (Figure 50).
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Figure 51: The citation will appear and can be downloaded in different formats.

The citation will appear and can be downloaded in different formats (Figure 51).

Then, you can also add citation for the second scene using “funnel.bib”. Since the process

is the same, we will not repeat it again.

Congratulation!! You have completed the entire MD showcase tutorial. It’s time for you

to try it using your own molecule or trajectories.
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[2] Kerstin Göpfrich*, Chen-Yu Li*, Maria Ricci, Satya Prathyusha Bhamidimarri, Jejoong

Yoo, Bertalan Gyenes, Alexander Ohmann, Mathias Winterhalter, Aleksei Aksimentiev,

and Ulrich F Keyser. Large-conductance transmembrane porin made from DNA origami.

ACS Nano, 10(9):8207–8214, 2016.


	Introduction
	Content of the tutorial files
	Introduction to a showcase
	Found a bug in the tool

	Create the first showcase
	Create a scene in the showcase
	Share the showcase

	Create an animated showcase
	Rotation
	Rock and roll
	Controlling the camera with a ``view script''
	Combine previous examples with a view script

	Create multiple scenes with MD simulation trajectories
	Create a showcase with a MD trajectory
	Add another scene with multiple molecules

	Enrich the showcase
	Add snapshots for each scene
	Add description
	Add frame-related comment
	Add citation


