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Introduction

This tutorial is designed to guide users of VMD and NAMD in all the steps re-
quired to determine permeation and electrostatic properties of membrane chan-
nels. The tutorial assumes that you already have a working knowledge of VMD
and NAMD. For the accompanying VMD and NAMD tutorials go to:
http://www.ks.uiuc.edu/Training/Tutorials/
This tutorial has been designed specifically for VMD 1.8.5 and NAMD 2.6, and
should take about X hours to complete in its entirety.

The tutorial is subdivided into two separate units. The first unit covers the
analysis of equilibrium membrane-channel simulations. The second unit de-
scribes the steps needed to induce a voltage across a pore-containing membrane
and the techniques used to analyze such non-equilibrium simulations.

The examples in the tutorial will focus on the study of a membrane chan-
nel model made of an artifical membrane featuring a carbon nanotube pore.
Throughout the text, some material will be presented in separate “boxes”.
These boxes include complementary information to the tutorial, such as in-
formation about the biological relevance of ion transport across membranes,
and tips or technical details that can be further explored by the advanced user.

If you have any questions or comments on this tutorial, please email the TCB
Tutorial mailing list at tutorial-l@ks.uiuc.edu. The mailing list is archived at
http://www.ks.uiuc.edu/Training/Tutorials/mailing list/tutorial-l/.

Membrane Channels. Selective and controled transport of so-
lutes (ions and others) across the cellular membrane is essential
for the survival of cells and multicellular organisms. Transport of
ions through membrane channels play fundamental roles in biologi-
cal processes such as cell volume regulation and neuronal signaling.
In this tutorial we will study permeation properties of membrane
channels by using a simplified artificial membrane featuring a pore
made of a carbon nanotube. This system is simple and easy to
simulate, while the same principles and analysis techniques can be
applied to simulations of more complex protein channels.
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Required programs

The following programs are required for this tutorial:

• VMD: Available at http://www.ks.uiuc.edu/Research/vmd/ (for all plat-
forms)

• NAMD: Available at http://www.ks.uiuc.edu/Research/namd/ (for all
platforms)

• MATLAB

Getting Started

You can find the files for this tutorial in the ion-tutorial-files directory.
Below you can see in Fig. 1 the files and directories of ion-tutorial-files.

iontut-files

cntwief-01a.conf

cntwieq-01.conf

cntwi_fix.pdb

cntwi.pdb

cntwi.psf

example-output

par_all27_prot_lipid.prm

Figure 1: Directory structure of memtut-files

To start VMD type vmd in a Unix terminal window, double-click on the VMD
application icon in the Applications folder in Mac OS X, or click on the Start
→ Programs → VMD menu item in Windows.
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1 Analysis of Equilibrium Simulations

In this unit you will perform and analyze a simulation of an artificial membrane
channel system, learning how to compute densities, osmotic permeabilities, and
electrostatic maps.

1.1 The Artificial Membrane Channel System

Our first step is to get familiarized with the system under study.

1 Navigate to the directory containing the tutorial files
("<your-home-directory>/iontut/ion-tutorial-files/").
Open VMD and load the files cntwi.psf and cntwi.pdb.

2 Choose the Graphics → Representations... menu item and create the fol-
lowing two representations: You should be able to identify two layers of

Selection Drawing Method Coloring Method
not (water or ions) VDW Name
ions VDW Name

atoms forming an artificial membrane, a wide pore in the middle of the
membrane formed by a carbon nanotube, and ions.

3 Turn off the ions representation and select the Mouse → Label → Bond
menu item (or use the shortcut key 2). Measure the diameter of the pore
by clicking on two atoms located at opposite edges of the pore-forming
nanotube. The diameter should be about 26 Å

Wide and Narrow Membrane Channels. Membrane proteins form
channels with diverse and complex properties. For instance, potas-
sium ion channels feature a pore formed by a very narrow selectiv-
ity filter (just wide enough to fit a desolvated ion) and a slightly
wider intracellular vestibule (pdb code 1K4C). On the other hand,
α-hemolysin (pdb code 7AHL) exhibits a wide (13 Å in diameter),
non-selective pore. Electrostatic and transport properties for both
types of channels can be studied with molecular dynamics simula-
tions.

Carbon Nanotubes. Nanotubes are cylinders (a few nanometers in
diameter) formed by hexagonal graphite layers which exhibit remark-
able mechanical, optical, and electronic properties. In the present
tutorial, we use a so called (20,12) carbon nanotube to mimick a
membrane channel. The nanotube is used as a wide pore suitable
for the study of water and ion transport across membranes.
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Now we will determine some specific properties of the system such as the num-
ber of water molecules and ions in the system.

4 Open the Tk Console window by selecting the Extensions → Tk Console
menu item. Create selections for all atoms, water, chloride, and sodium
ions by typing:
set all [atomselect top "all"]
set chloride [atomselect top "name CLA"]
set sodium [atomselect top "name SOD"]
set water [atomselect top "name OH2"]

Note that we have selected only oxygen atoms for water.

5 Determine the number of atoms in each selection by typing:
$chloride num
$sodium num
$water num

Can you estimate the ionic concentration used in this system? (Hint: the
molar concentration of water is 55 M and NA = 6.022× 1023)

6 Now proceed to determine the radii of all atoms, and of chloride and
sodium ions in particular, by typing in the Tk Console:
lsort -unique [$all get radius]
lsort -unique [$chloride get radius]
lsort -unique [$sodium get radius]

We have used the get command to obtain the radius of atoms contained
in a selection. The Tcl command lsort -unique allowed us to sort the
resulting list of radii and delete all redundant elements.

VMD Radii. VMD uses a periodic table lookup to determine atomic
mass and VDW radii when information about the atom element is
available, otherwise it will guess radii using an atom name recognizer
heuristic. In the present case, VMD assigned radii of 1.75 Å and
2.27 Å to chloride and sodium ions, respectively. The Pauling radii
are actually 0.95 Å and 1.81 Å for Na+ and Cl−, while the radii
used in simulations is determined from the VDW parameters of the
CHARMM force field.

For purely visualization purposes, we will set the radii of Cl− and Na+ to the
values determined by Pauling.

7 Type in the Tk Console:
$chloride set radius 1.81
$sodium set radius 0.95
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8 Finally, determine the charge of your system by typing in the Tk Console:

measure sumweights $all weight charge

The net charge of your system should be zero. Keep VMD open for the
next section.

1.2 Membrane Channel in Electrolyte at 0 Volts

Now that you are familiar with the system, we will perform and analyze a molec-
ular dynamics simulation of the membrane channel in electrolyte at 0 Volts.

1 Navigate to the tutorial directory named (ion-tutorial-files) and open
with a text editor the file cntwieq-01.conf.

2 Look at the NAMD configuration file and note that we are using a 1 fs
timestep with a multiple time-stepping algorithm that permits computa-
tion of short-range non-bonded interactions every 2 fs, and of long-range
non-bonded interactions every 4 fs.

3 Locate the section labeled # Fixed Atoms Constraint. NAMD will fix
atoms which have an Occupancy value different from 0 in the file cntwi fix.pdb.

4 Locate the section labeled # Constant Pressure Control. The simula-
tion will be performed in the NpT ensemble (constant number of particles
N; constant pressure p; constant temperature T). However, note that we
will keep the area of the system constant (useConstantArea yes), since
the artificial-membrane atoms will be kept fixed in this particular example.

5 Close the text editor and proceed to run your simulation using NAMD as
indicated below.

Running. Use NAMD to run your simulation. The usual command
to run your job is namd2 cntwieq-01.conf > cntwieq-01.log,
but it may be different depending on your local system configuration.
The simulation should take about 24 hours in a single processor
machine. You may want to skip this step and use the trajectory files
already available in the example-output directory.

We will now proceed to visualize and analyze the outcome of the simulation.

6 In the current VMD session, which should be displaying the cntwi.psf
molecule, load the trajectory cntwieq-01.dcd by selecting the File →
Load Data Into Molecule... menu item. Be sure you load the file into the
existing molecule! As the file loads, you should be able to see ions moving
around the simulation box.
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Selection Drawing Method Coloring Method
water Lines Name

7 Select the Graphics → Representations... menu item and create the follow-
ing new representation:

You should be able to see water molecules. Do they permeate the pore?

1.3 Computing Water Density

Lets determine the average density of water in all regions of our system.

1 If the Tk Console is not open already, select the Extensions → Tk Console
menu item. Then type the following commands in the Tk Console:

set wat [atomselect top "name OH2"]
volmap density $wat -allframes -combine avg -res 1 -o eqwatdens.dx

The execution of the latter command may take a few minutes and will
generate a volumetric data set, stored in eqwatdens.dx, which contains
the average density of water molecules computed over a matrix of cubic
voxels (1 Å3 each).

2 Load the generated data set by typing mol load dx eqwatdens.dx. Be
sure that you are located in the appropriate directory first. The volumetric
dataset will be loaded as a new molecule, but in the VMD OpenGL Display
window you will only see a cube that delimits the region used to compute
the density

3 In order to visualize the density, go to the Graphical Representations win-
dow. Make sure that under Selected Molecule it reads 1:eqwatdens.dx.
The default drawing method for a volumetric data set is Isosurface.
Change it to VolumeSlice and select the Volume coloring method.

4 In the Graphical Representations window, set the Render Quality to Medium,
and move the slice offset to 0.50. Rotate your molecule, you should be able
to see something similar to what is shown in Fig. 2. Turn off the cntwi.psf
molecule (double click on the D close to the name of the molecule in the
VMD Main window) for better visualization.

5 Set the Slice Axis to Y or Z and explore the density dataset along the pore.

6 Select the Extensions → Visualization → Color Scale Bar menu item; the
corresponding window should appear in your screen. Turn Autoscale On
and click on the Draw Color Scale Bar button.
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Figure 2: Water density as determined by the VMD volmap plugin.

A color scale bar should appear in your VMD OpenGL Display window. Den-
sity values for water fluctuate between 0.028 and 0.037 × atoms ×Å−3. Do
these values make sense? Compute the average water density in mol/L using
1 L=0.001 m3 and NA=6.0221×1023 mol−1. Compare it to the standard water
concentration value (55 mol/L).

7 Press the Delete Color Scale Bar and leave open your VMD session for the
next section.

1.4 Computing Ionic Density

We will now follow a similar procedure to compute the density of ions in the
simulation cell.

1 In the Tk Console type the following commands:
mol delete top
set cl [atomselect top "name CLA"]
volmap density $cl -allframes -combine avg -res 1 -o eqcldens.dx

Computation of chloride density may take a few seconds.

2 Once the computation is done, load in VMD the resulting file (eqcldens.dx)
as a new molecule. In the Graphical Representations window change the
default Isosurface representation to VolumeSlice and then select the
Volume Coloring Method. Set the Slice Axis to Z and visually inspect the
Cl− density.

The range of values for Cl− densities is more hetereogenous than that observed
for water. Use the Color Scale Bar to determine approximate boundaries for the
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ionic concentration of the system. Follow the same procedure outlined above
to make an estimate of the ionic concentration. Does the number compare well
with your earlier estimate of ionic concentration based on the number of ions
and water molecules?

3 Once you are done, press the Delete Color Scale Bar button.

4 Lets follow the same procedure to compute densities for sodium ions:

mol delete top
set na [atomselect top "name SOD"]
volmap density $na -allframes -combine avg -res 1 -o eqnadens.dx

5 Again, load the resulting file (eqnadens.dx) as a new molecule and explore
the Na+ density. Once you are done exploring, delete the top molecule
(corresponding to the Na+ density file).

1.5 Computing Electrostatic Maps

In addition to densities of ions and water, VMD permits one to compute the
average electrostatic potential of a molecular dynamics trajectory by using the
PMEpot plugin.

Long Range Electrostatics. The particle mesh Ewald method
(PME) permits the efficient computation of long range electrostatic
interactions. The VMD plugin PMEpot evaluates the reciprocal sum
of the smooth particle-mesh Ewald method resulting in a smoothed
electrostatic potential. In order to use it, you must have a periodic
and neutral system. The algorithm approximates point charges us-
ing Gaussians with sharpness controlled by the Ewald factor, more
details can be found in Aleksij Aksimentiev and Klaus Schulten,
Biophysical Journal, 88:3745–3761, 2005

1 Be sure that the top molecule corresponds to cntwi.psf containing all
frames of our equilibrium molecular dynamics trajectory. Type the fol-
lowing commands in the Tk Console:

package require pmepot
set all [atomselect top "all"]
pmepot -sel $all -frames all -xscfile cntwieq-01.restart.xsc \
-grid {48 48 48} -dxfile eqpot.dx -ewaldfactor 0.25

The PMEpot plugin will compute the electrostatic potential for each frame
and then will average it over the entire trajectory (VMD will take a few
minutes to finish with the computations).
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Figure 3: Electrostatic potential as determined by the VMD PMEpot plugin.

The electrostatic potential is calculated using all the atoms of the system, a
three dimensional grid of 48 × 48 × 48 points (which ensures at least one grid
point per Å in each direction), and an Ewald factor of 0.25.

Warning. Note that the periodic cell size has been read from
cntwieq-01.restart.xsc, which contains the fixed cell size cap-
tured at the end of the equilibrations. Using this file is NOT quite
correct, since the simulation was performed at constant pressure
and, therefore, the size of the simulation cell changed for each frame.
However, for illustration purposes we will use it anyway.

Finally, note that the electrostatic potential will be stored as a threee-dimensional
data set in the file eqpot.dx and will be automatically loaded as a separate
molecule in VMD.

2 Lets inspect the resulting electrostatic potential map. Open the Graphical
Representations window and change the default Isosurface representa-
tion to VolumSlice. Then select the Volume Coloring Method. Set the
Slice Axis to Z and move the slice offset to 0.50.

3 Rotate your molecule, you should be able to see something similar to what
is shown in Fig. 3.

4 Select the Extensions → Visualization → Color Scale Bar menu item; the
corresponding window should appear in your screen. Turn Autoscale On
and click on the Draw Color Scale Bar button.
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A color scale bar should appear in your VMD OpenGL Display window.
The electrostatic potential generated by PMEpot is in units of kT/e. Us-
ing T = 300 K, one PMEpot unit of electrostatic potential is equivalent to
0.0258 Volts.

The computed electrostatic potential ranges from -7.22 to 9.94 kT/e, which
is equivalent to a total variation of about 0.5 Volts. The largest variation of
electrostatic potential occurs at the interface between water molecules and the
membrane/channel atoms. Moreover, the electrostatic potential in the inte-
rior of the membrane (vacuum in our artificial example) is homogeneous and
positive, while the potential throughout the zones occupied by water is rather
inhomogenous and negative (with variations of at most 0.2 V). Such potential
is consistent with the membrane dipole potential caused by interfacial dipoles.
The inhomogeneity observed in the region occupied by water is caused by poor
sampling.

We now have completed the analysis of a membrane-channel molecular dynam-
ics simulation at 0 Volts. In the next section, we will learn how to induce a
voltage difference across our artificial membrane and will analyze the outcome
of the corresponding simulations.
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2 Analysis of Non-Equilibrium Simulations

In this second unit, you will learn how to induce a voltage difference across a
pore-containing membrane and perform analysis of the resulting non-equilibrium
molecular dynamics simulation.

2.1 Membrane Channel in Electrolyte at 1 Volt

We will use the same system described in the previous unit, but will now per-
form a simulation in which an external electric field induces a voltage difference
across the pore-containing membrane.

1 Navigate to the tutorial directory ion-tutorial-files and locate the
NAMD configuration file cntwief-01a.conf. Open the file with a text
editor.

2 Locate the section labeled # Continuing a job from the restart files
and check that we are using the outcome of the simulation performed in
unit 1 as a starting point. As usual, its always desirable to start a simu-
lation using an equilibrated system.

3 Since we are restarting from a previous simulation, it is not necessary to
define the NAMD temperature or the size of the simulation cell, which are
commented out in the NAMD configuration file as you can check yourself
(Tcl comments always start with the symbol #).

4 We will perform the simulation in the NVT ensemble (constant number
of particles N; constant volume V; constant temperature T). Locate the
section labeled # Constant Pressure Control and check that is not ac-
tive (if{0} { will always be false and the content inside the brackets will
not be taken into account when reading the parameter file).

5 Finally, locate the section labeled ## EXTRA PARAMETERS in the NAMD
configuration file. You should find the following NAMD commands:

eFieldOn yes
eField 0 0 0.54

The first command turns on an electric field that will be applied to all
atoms in the system. The second command sets the electric field to be
used. The electric field is specified as a vector which, in this particular
case, has only a z component. The electric field unit used by NAMD is
the kcal/mol/Å/e; one unit is equivalent to 0.0434 Volts/Å.

6 Locate the file named cntwieq-01.restart.xsc. This file contains infor-
mation about the periodic-simulation cell size. Open the file with a text
editor, you should see text similar to:
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# NAMD extended system configuration restart file
#$LABELS step a_x a_y a_z b_x b_y b_z c_x c_y c_z o_x o_y o_z s_x s_y s_z s_u s_v s_w
910000 46 0 0 0 46 0 0 0 42.651 0 0 0 -0.000440762 -0.00058589 -9.2304e-05 0 0 0

7 Note that the size of the system in the z direction decreased from its
original value (c x changed from 46 Å to 42.651 Å in the present exam-
ple). Record the value of c x found in your file and close the text editor
containing the file cntwieq-01.restart.xsc. Then go back to the text
editor containing the file cntwief-01a.conf.

The constant electric field ~E applied to
the system, as set in the NAMD con-
figuration file (eField 0 0 0.54), will
induce an electrostatic potential drop
across the simulation cell that can be
computed from:

∇φ = − ~E (1)
⇒ φ = E Lz (2)

The potential drop across the simula-
tion cell is then about 1 V in our partic-
ular example (0.54×0.0434×42.651 V).
Since water molecules and ions are free
to move around the simulation cell,
they will rearrange in order to restore a
flat electrostatic potential in bulk elec-
trolyte. Thus, ions and water molecules
will generate a reaction potential that,
when added to the applied potential,
will result in the total electrostatic
potential of the system illustrated in
Fig. 4.
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Figure 4: Applied, reaction, and result-
ing electrostatic potentials

8 If you are doing this tutorial with a group of people, set the value of
the electrostatic field in the NAMD configuration file cntwief-01a.conf
so as to apply an electrostatic potential drop equivalent to the month
of your birthday multiplied by 0.5 V. For instance, if your birthday is in
March, set it to 1.5 V. Note that you have to use the cell size you recorded
earlier to determine the value of the electric field in units of kcal/mol/Å/e.
Following our example, we would replace eField 0 0 0.54 by eField 0
0 0.162.
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9 If you are doing this tutorial by yourself, set the value of the electrostatic
field so as to apply an electrostatic potential drop of 1 V. Note that you
have to use the cell size you recorded earlier to determine the value of the
electric field in units of kcal/mol/Å/e. In our example, the electric field
is already set at the correct value.

Electrostatic Potentials. Osmotic imbalances between the cell’s
interior and its surroundings cause electrostatic potentials of a few
hundred millivolts to arise across cell membranes. Such potentials
influence conformation and permeation properties of membrane pro-
teins. Patch clamp experiments, whereby electrodes placed at op-
posite sides of a membrane produice an electric field, are used to
study the behavior of membrane proteins under the action of a con-
trolled electrostatic potential. The principles behind patch-clamp
experiments are the same of those behind molecular dynamics sim-
ulations in which an electric field is applied to the whole system.
Note that we are using unusually large electrostatic potentials in
order to obtain results during the short time-scales achievable by
simulations.

10 Save and close the modified NAMD configuration file. Proceed then to
run your simulation as indicated below.

Running. Use NAMD to run your simulation. The usual command
to run your job is namd2 cntwief-01a.conf > cntwief-01a.log,
but it may be different depending on your local system configuration.
The simulation should take about 24 hours in a single processor
machine. You may want to skip this step and use the trajectory files
already available in the example-output directory.

11 Once the simulation is done, proceed to open VMD, launch the Tk Console
window, and load the resulting trajectory by typing:
mol load psf cntwi.psf dcd cntwief-01a.dcd

12 Select the Graphics → Representations... menu item and create the follow-
ing two representations:

Selection Drawing Method Coloring Method
ions VDW Name

Rotate the image so as to have the z-axis pointing up in your screen.

13 Use the VMD main window controls to play the trajectory back and forth.
You should be able to see positive sodium ions moving across the center of
the channel in the positive z direction, and negative chloride ions moving
in the negative z direction.
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2.2 Computing density of water

Lets determine whether the applied field changed the average density of water
in some regions of the system.

1 Type the following commands in the Tk Console window:
set wat [atomselect top "name OH2"]
volmap density $wat -allframes -combine avg -res 1 -o efwatdens.dx

The execution of the latter command may take a few minutes and will
generate a volumetric data set, stored in efwatdens.dx, which contains
the average density of water molecules computed over a matrix of cubic
voxels (1 Å3 each).

2 Following the same approach used in the previous unit, load the generated
data set by typing mol load dx efwatdens.dx. The volumetric dataset
will be loaded as a new molecule, but in the VMD OpenGL Display window
you will only see a cube that delimits the region used to compute the
density

3 In order to visualize the density, go to the Graphical Representations win-
dow. Make sure that under Selected Molecule it reads 1:efwatdens.dx.
The default drawing method for a volumetric data set is Isosurface.
Change it to VolumeSlice and select the Volume coloring method.

4 In the Graphical Representations window, set the Render Quality to Medium,
and move the slice offset to 0.50. Rotate your molecule, you should be able
to see something similar to what is shown in Fig. 5. Turn off the cntwi.psf
molecule (double click on the D close to the name of the molecule in the
VMD Main window) for better visualization. Do you notice a differece be-
tween the water density computed for this simulation in which an electric
field has been applied, and the water density obtained for our previous
simulation in equilibrium?

5 Set the Slice Axis to Y or Z and explore the density dataset along the pore.

6 Select the Extensions → Visualization → Color Scale Bar menu item; the
corresponding window should appear in your screen. Turn Autoscale On
and click on the Draw Color Scale Bar button.

A color scale bar should appear in your VMD OpenGL Display window. Den-
sity values for bulk water fluctuate between 0.025 and 0.038 × atoms ×Å−3. Do
these values make sense? Compute the average water density in mol/L using
1 L=0.001 m3 and NA=6.0221×1023 mol−1. Compare it to the standard water
concentration value (55 mol/L) and the value you computed in the previous
unit.
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Figure 5: Water density as determined by the VMD volmap plugin.

7 Press the Delete Color Scale Bar and leave open your VMD session for the
next section.

2.3 Computing Density of Ions

We will now follow a similar procedure to compute the density of ions in the
simulation cell.

1 In the Tk Console type the following commands:

mol delete top
set cl [atomselect top "name CLA"]
volmap density $cl -allframes -combine avg -res 1 -o efcldens.dx

Computation of chloride density may take a few seconds.

2 Once the computation is done, load in VMD the resulting file (efcldens.dx)
as a new molecule. We will use in this case the default Isosurface
representation In the Graphical Representations window change the
Isovalue to 0.001 and then change the Draw option from Points to Solid
Surface. Finally, change the Material from Opaque to Transparent. You
should be able to see the distribution of Cl ions around the cell as shown
in Fig. 6.

The range of values for Cl− densities is more hetereogenous than that observed
for water. Use the Color Scale Bar to determine approximate boundaries for the
ionic concentration of the system. Follow the same procedure outlined above to
make an estimate of ionic concentration. Does the number compare well with
your earlier estimate of ionic concentration based on the number of ions and
water molecules? Do you observe a difference between the distribution of ions
around the simulation cell observed in simulations with and without applied
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electric field?

3 Once you are done, press the Delete Color Scale Bar button.

4 Lets follow the same procedure to compute densities for sodium ions:

mol delete top
set na [atomselect top "name SOD"]
volmap density $na -allframes -combine avg -res 1 -o efnadens.dx

5 Again, load the resulting file (efnadens.dx) as a new molecule and explore
the Na+ density using the Isosurface representation. Compare your results
with the ionic density computed in equilibrium (without field). Once you
are done exploring, delete the top molecule (corresponding to the Na+

density file).

Figure 6: Chloride and Sodium density as determined by the VMD volmap
plugin.

2.4 Computing Electrostatic Maps

Lets use VMD to compute the average electrostatic potential of the molecu-
lar dynamics trajectory by using the PMEpot plugin. Note that the computed
electrostatic potential will be the reaction potential described in Fig. ??

1 Be sure that the top molecule corresponds to cntwi.psf containing all
frames of our molecular dynamics trajectory with an applied field. Type
the following commands in the Tk Console:
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package require pmepot
set all [atomselect top "all"]
pmepot -sel $all -frames all -xscfile cntwief-01a.restart.xsc \
-grid {48 48 48} -dxfile efpot.dx -ewaldfactor 0.25

The PMEpot plugin will compute the electrostatic potential for each frame
and then will average it over the entire trajectory (VMD will take a few
minutes to finish with the computations).

Figure 7: Electrostatic potential as determined by the VMD PMEpot plugin.

The electrostatic potential is calculated using all the atoms of the system, a
three dimensional grid of 48 × 48 × 48 points (which ensures at least one grid
point per Å in each direction), and an Ewald factor of 0.25.

Finally, note that the electrostatic potential will be stored as a threee-dimensional
data set in the file efpot.dx and will be automatically loaded as a separate
molecule in VMD.

2 Lets inspect the resulting electrostatic potential map. Open the Graphical
Representations window and change the default Isosurface representa-
tion to VolumSlice. Then select the Volume Coloring Method. Set the
Slice Axis to Z and move the slice offset to 0.50.

3 Rotate your molecule, you should be able to see something similar to what
is shown in Fig. 7. Is the potential similar to the reaction potential shown
in Fig. reffig:diagram2?

4 Select the Extensions → Visualization → Color Scale Bar menu item; the
corresponding window should appear in your screen. Turn Autoscale On
and click on the Draw Color Scale Bar button.

A color scale bar should appear in your VMD OpenGL Display window. As we
mentioned before, the electrostatic potential generated by PMEpot is in units
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of kT/e. Using T = 300 K, one PMEpot unit of electrostatic potential is equiv-
alent to 0.0258 Volts.

The computed electrostatic potential ranges from -14.270 to 15.775 kT/e, which
is equivalent to a total variation of about 0.77 Volts, close to the expected 1 Volt.
Note that since the system studied is small, and the simulation lasted a short
time, the potential is unlikely to be completely stabilized. It may take several
nanoseconds to achieve an steady state.

The total electrostatic potential of the system can be obtained by adding the
linear applied potential to the measured reaction potential. We show in the
right panel of Fig. 7 the outcome of the addition, resulting in flat negative and
positive potentials at each side of the membrane, as expected for the total elec-
trostatic potential. Future versions of the PMEpot plugin will allow you to
add the corresponding applied bias automatically. Future versions of VMD will
allow you to extract potential and density one- or two- dimensional profiles.

2.5 Computing Ionic Currents

When exploring the trajectory of the simulation in which we applied an external
electric field, you noticed that ions translocated across the pore of our artificial
membrane. Ionic currents can be computed by counting the number of ions that
cross the channel, i.e.:

I =
N q

τ
(3)

where N is the number of crossing events over a time interval τ . The ionic
current can also be estimated by using:

I(t) =
1

∆t Lz

N∑
i=1

qi[zi(t + ∆t)− zi(t)] (4)

as outlined in Aleksij Aksimentiev and Klaus Schulten, Biophysical Journal,
88:3745–3761, 2005.

Warning. Be extremelly careful when reporting ionic currents, as
the values you obtain may depend on several simulation parameters,
such as the use of Langevin Dynamics or PME electrostatics. For
instance, it is well knwon that the TIP3P model of water exhibits a
difussion coefficient that is larger than the experimentally observed
value. It is also known that the use of langevin dynamics adds
an additional artificial viscocity playing against the ion movement.
Thus, we strongly recommend you perform a calibration of ionic
currents in bulk electrolyte. Moreover, note that you can estimate
the statistical error of your sample by using the root square of the
number of permeation events, which for a few events can be rather
large (I = Im/

√
N ).
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Homework. Write a script that permits you to compute the ionic
current across a channel given a moleculer dynamics trajectory. The
script should compute the ionic current by either counting the num-
ber of ions crossing the transmembrane pore, or by measuring the
displacement current defined in Eq. 4

This ends the Ion Conduction and Electrostatic Maps tutorial. We hope that
you learned a lot with it, and that you will be able to apply similar analysis
tools to your own molecular dynamics simulations.


